Tuesday, July 10, 2018

UVA 11631-Dark Roads

Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.
What is the maximum daily amount of money the government of Byteland can save, without making
their inhabitants feel unsafe?

 

Input

The input le contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m = n = 0. Otherwise, 1 <=m <= 200000 and m-1 <=n <=200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 <=x; y < m and x ̸= y). The graph speci ed by each test case is connected. The total length of all roads in each test case is less than 2^31.

 

Output

For each test case print one line containing the maximum daily amount the government can save.

 

Sample Input

7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0

Sample Output

51

 

Analysis

This Problem can be solved by using Minimum Spanning Tree (MST). We have learned about Kruskal algorithm. Here in the problem we are told to find out maximum amount of saving of government for lighting the street. Firstly we will calculate total cost for lighting the streets. Then we will apply Kruskal algorithm. After that from total cost we will deduct the amount found by kruskal algorithm. By this we can easily find maximum amount of  saving.

Solution  


#include <bits/stdc++.h>
using namespace std;

struct edge
{
    long long int u;
    long long int v;
    long long int w;
};

bool cmp(edge a, edge b)
{
    return a.w<b.w;
}

long long int pr[200100], n, m, mst, s[200100];
edge e[200100];

long long int find_set(long long int r)
{
    if(pr[r]==r)
        return r;
    else
        find_set(pr[r]);
}

long long int kruskal()
{
    sort(e,e+m,cmp);
    long long int cnt=0;

    for(long long int i=0; i<m && cnt<n-1; i++)
    {
        long long int u=find_set(e[i].u);
        long long int v=find_set(e[i].v);

        if(u!=v)
        {
            if(s[u]>s[v])
                swap(u, v);
            s[v]+=s[u];
            mst+=e[i].w;
            pr[u]=v;
            cnt++;
        }
    }
}

int main()
{
    long long int u,v,w;
    while(scanf("%lld%lld", &n, &m)==2)
    {
        if(n==0 && m==0)
            break;
        mst=0;
        long long int total=0;
        for(long long int i=0; i<m; i++)
        {
            pr[i]=i;
            s[i]=1;
            scanf("%lld%lld%lld", &u, &v, &w);
            total+=w;
            edge get;
            get.u=u;
            get.v=v;
            get.w=w;
            e[i]=get;
        }
        s[m]=1;
        pr[m]=m;
        kruskal();
        printf("%lld\n", total-mst);
    }
    return 0;
}

No comments:

Post a Comment