John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3
Analysis
In this problem we are said to order some tasks. As every task is not independent, so we can use Toplogical Sort algorithm here to solve.
Solution
#include<bits/stdc++.h>
using namespace std;
vector <int> G[105];
vector <int> processed;
queue <int> q;
int n, m;
int indegree[105];
void topsort()
{
int u;
while(!q.empty())
{
u=q.front();
q.pop();
processed.push_back(u);
for(int i=0; i<G[u].size(); i++)
{
int v=G[u][i];
indegree[v]--;
if(indegree[v]==0)
{
q.push(v);
}
}
}
}
int main()
{
int u, v;
while(scanf("%d%d", &n, &m)==2)
{
if(n==0 && m==0)
break;
memset(indegree, 0, sizeof(indegree));
for(int i=0; i<m; i++)
{
scanf("%d%d", &u, &v);
indegree[v]++;
G[u].push_back(v);
}
for(int i=1; i<=n; i++)
{
if(indegree[i]==0)
{
q.push(i);
}
}
topsort();
for(int i=0; i<processed.size(); i++)
{
if(i== (processed.size()-1))
{
printf("%d", processed[i]);
}
else
{
printf("%d ", processed[i]);
}
}
processed.clear();
for(int i=1; i<=n; i++)
{
G[i].clear();
}
printf("\n");
}
return 0;
}